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About this Guide

This User's Guide applies to MAN B&W Diesel's Off-line PMI System. It 
provides an introduction to and an overview of the entire PMI System for 
off-line cylinder pressure measurements on MAN B&W Diesel engines 
on board ship and at stationary power plants.

The guide sets out to provide engine staff with the knowledge essential for 
understanding the principle of operation and function of the PMI System, 
so that they can more quickly begin using it for measurements.

Before starting to use the PMI System, it is essential that it is correctly 
installed by qualified service personnel. Full instructions for doing this 
are available in the separate Mounting and Installation Guides which are 
provided with the system. 

Copyright © 1999 – 2005, MAN B&W Diesel A/S

All rights reserved. No part of this publication may be reproduced or distributed 
in any form or by any means, without prior consent in writing from MAN B&W 
Diesel A/S.
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Conditions of Licence

The supply, distribution and use of the PMI System and Data media, including 
System Documentation, are subject to your acceptance of the Standard 
Conditions of Licence which are supplied in the Software Package containing the 
PMI System.

Taking the PMI System in use will indicate your acceptance of these 
conditions.

Trademarks

Windows is a trademark of the Microsoft Corporation, U.S.A.
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Chapter 1

Before You Begin

Welcome to MAN B&W Diesel's Off-line PMI System for cylinder pres-
sure measurements and analysis on diesel engines.

The PMI System is designed to provide engineers and service staff on 
board ship and at power plants with a computerised tool for cylinder pres-
sure measurements on MAN B&W two and four stroke diesel engines.

It consists of a pressure transducer, a PMI Controller and a trigger system 
with crankshaft pickup which can be operated using an IBM compatible 
PC on which the PMI System software is installed. The system is supplied 
with the necessary hardware and software, and is designed to automati-
cally calculate, display and log measurement results. Primary features 
include:

• Graphic presentation of PT, PV and Balance Diagrams, together with 
Mean Indicated Pressure and Maximum Pressure deviation limits

• Calculated values of Effective Power, Mean Indicated Pressure pi, 
Compression Pressure pcomp, Maximum Pressure pmax and Scavenge 
Pressure pscav, including proposed values for Index Adjustments, etc.

• Print out of results.

• Software interface for use with MAN B&W Diesel's engine perform-
ance and engine diagnostics software, e.g. CAPA Performance and 
CoCoS-EDS

In this Chapter

• About this User's Guide ............... 1 - 2

• PMI System's 'On-line Help' ....... 1 - 3

• Conventions ................................... 1 - 4
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1.1 About this User's Guide

This User's Guide is prepared to give the knowledge essential to under-
standing the concept, structure and function of the PMI System.

The guide is structured to provide both brief and detailed information in 
order that you can quickly and easily obtain an overview of the PMI Sys-
tem, as well as become familiar with the majority of its commands.

The guide includes the following chapters:

Chapter 1 – Before You Begin: This is the chapter which you are now 
reading. It provides a brief introduction to the PMI System 
and the contents of this User's Guide, and includes details 
about text conventions.

Chapter 2 – Getting to Know the PMI System: This provides a short, 
but detailed account about the PMI System so that you can 
quickly gain an overview of its main applications and fea-
tures.

Chapter 3 – Exploring the PMI System: This deals with basic opera-
tion of the PMI System. It explains what you need to know 
in order to start using the program for viewing measure-
ments.

Chapter 4 – Pressure Measurements: This chapter concerns making 
pressure measurements with the PMI System, editing them 
and creating backups of your database.

Chapter 5 – The System Menus & Commands: This provides a sim-
plified overview of the commands available with the menu 
system of the PMI System.

Appendix – This gives brief information on the system requirements 
for using the PMI System on your computer and advice on 
troubleshooting.

Glossary – This explains many of the terms and abbreviations used 
throughout this guide
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For detailed information and instructions concerning installation and set-
up of the PMI System, please consult the separate Mounting and Installa-
tion Guides which are provided with the system. 

1.2 PMI System's 'On-line Help'

To help you in hands on use of the PMI System, its application software 
includes on-line help information. This is available directly on your PC 
whenever using it together with the PMI System. It is activated by pressing 
the function key 'F1' on the keyboard and explains about each of the com-

Fig. 1-1. System documentation available for the Off-line PMI System
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mands and functions that are available for making measurements, display-
ing, editing and deleting measurement results.

1.3 Conventions

Illustrations: 

The illustrations shown in this guide are examples only and although typi-
cal of what you can expect to see when using the PMI system, depend on 
the particular engine plant and crankshaft pickup employed.

Settings & Values:

The values and settings shown in the displays and stated in accompanying 
text throughout the guide, are included as examples only.

Menus & Menu Commands:

References to specific commands that are given in menus and dialogue 
boxes are indicated in single quotes, e.g. 'Open Engine' in the 'File' menu.

Commands depicted with a leader, i.e. 'Options ...', open a selection dia-
logue which offer a number of options to choose from, while those without 
a leader, i.e. ' Print', immediately initiate the particular action designated.

Suffixes to measurement parameters are given in parentheses in the PMI 
application and in subscript in the User Guide. e.g. p(scav) = pscav.

For details on the conventions used for indicating mouse and keyboard 
functions with a PC, see section 3.2.2.
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Chapter 2

Getting to Know the PMI
System

This Chapter provides a short account about the PMI System. It describes 
its main applications and features so that you can obtain an insight into 
how it can help you with your day-to-day work on your diesel engine plant.

In this Chapter

• What is the PMI System? ............ 2 - 2

• The Basic System .......................... 2 - 2

• Main Features ............................... 2 - 6
Pressure Measurement Views......... 2 - 6
Calculated Values ........................... 2 - 8
Determination of TDC ................... 2 - 8
Crankshaft Torsion Correction ....... 2 - 8

Cylinder Identification.................... 2 - 9

• Supplementary Features............... 2 - 9
Standard PC Hardware.................... 2 - 9
Windows Display & Operation ..... 2 - 10
On-line Help ................................. 2 - 10
Data Backup.................................. 2 - 11
Use with Other Software............... 2 - 11
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2.1 What is the PMI System?

The PMI System is designed to provide engineers and service personnel 
onboard ship and at power plants with a portable computerised tool for cyl-
inder pressure measurements on MAN B&W two-stroke and four-stroke 
diesel engines.

The main advantages of the PMI System are:

• Easy to use and needs only one person to operate.

• Sensitive yet robust Pressure Transducer and PMI Controller Unit.

• Versatile trigger system. Operates with a variety of different pickups 
(angle encoder, light emitting and proximity pickups available) for 
detecting the crankshaft angle/rotation. It generates a large number of 
crankshaft angle/position pulses for optimum accuracy. No frequency 
multiplication is involved.

• Quick, reliable results. A complete set of measurement results takes 
less than 10 minutes to produce.

• Excellent accuracy compared to traditional indicating devices, includ-
ing other computerised systems for measurements on diesel engines.

• Uses a standard IBM compatible PC – yet requires no detailed know-
ledge of computers.

In addition, it has been field tested by MAN B&W Diesel's own service 
engineers and incorporates MAN B&W Diesel's accumulated know-how 
and expertise regarding diesel engine design, performance testing and 
measurements.

2.2 The Basic System

A schematic of the PMI System is shown in Fig. 2-1. 
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The off-line version of the system employs a high-performance piezo-elec-
tric transducer of well proven design which is mounted on the cylinder 
head indicator cock from which the cylinder pressure is measured. The 
transducer is manually moved from one cylinder to another between each 
set of measurements, and therefore is only exposed to the harsh environ-
ment of the combustion chamber for a very short period of time. This prin-
ciple results in very reliable and stable measurements. 

Fig. 2-1 Schematic of the Off-line PMI System (not to scale)
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To obtain a pressure indication which accurately describes the change in 
cylinder pressure throughout each work cycle of an engine, the pressure 
detected by the transducer must be synchronised with the motion of the 
engine. For this purpose, the PMI System is especially designed to be used 
with different types of crankshaft pickup, for example:

• Angle Encoder: A sealed unit which is fastened to engine crankshaft 
via a flexible coupling. It contains an externally driven, optically 
encoded disc, mounted between an internal light source and detector.

• LE- Pickup: A pair of light emitting sensors which detect the light 
reflected from a continuous strip of zebra tape bonded on the drive 
shaft of the engine. 

• PD-Pickup: A pair of proximity detectors which are based on induc-
tive pickups. They detect the rotation of a TDC marker and the individ-
ual teeth of a gear wheel or specially designed trigger ring at the aft of 
the crankshaft.

All types of pickup produce a train of electrical pulses which are used to 
detect the absolute position of the crankshaft. In addition, they produce a 
separate pulse which is used to synchronise the PMI System with the TDC 
position of Cylinder No. 1. 

Pickup Engine Type
& Layout

Mounting Maintenance

Angle
Encoder

Main & Aux.
Engines

without PTO

Engine Crankshaft via 
flexible coupling

Sealed unit requiring 
little or no 

maintenance

LE-Pickup 
&
Zebra Tape

Main & Aux. 
Engines with or 

without PTO

Zebra tape bonded on 
free section of engine 

drive shaft

Zebra tape must 
occasionally be 

cleaned

PD-Pickup Main & Aux. 
Engines with or 

without PTO

Operates from gear wheel 
or specially designed 
trigger ring on engine

Immune to most 
disturbances

Table 2-1  Crankshaft Pickups for use with the PMI System
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Fig. 2-2 Connection of PMI System with an Angle Encoder, Light-emitting and/or 
Proximity Pickups
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As indicated in Table 2-1 the choice of appropriate crankshaft pickup and 
its connection with the PMI System (see Fig. 2-2), depends on the engine 
layout.

With the Angle Encoder a precise number of crankshaft angle/position 
pulses are generated (e.g. 1024) per revolution of the crankshaft, while 
with the other sensors the number of pulses depends on the diameter of the 
drive shaft or the number of teeth on the gear wheel or trigger ring on the 
engine. 

The crankshaft pickup pulses from the engine are first fed to either an 
Intermediate Box or Frequency Divider and then on to a Junction Box. 
From there they are relayed to the portable PMI Controller which is 
attached to the pressure transducer and serves as the system's remote nerve 
centre for controlling measurements.   

All of the equipment is powered by an external 24 V DC source and except 
for the pressure transducer and portable PMI Controller, are mounted as a 
permanent fixture in situ with the engine. Both the PMI Controller and the 
Junction Box include the appropriate communication interfaces necessary 
to collect the data and automatically transfer it to a PC. For subsequent cal-
culation, display and storage of the data using the PC, the software sup-
plied with the PMI System must be installed.

2.3 Main Features

2.3.1 Pressure Measurement Views

The cylinder pressure measurements that are collected and stored in the 
database of the PMI System can be viewed on the PC using three different 
graphic presentation modes. These include PT Diagrams such as that 
shown in Fig. 2-3, as well as PV Diagrams and Balance Plots. 

In the particular case of the PT diagram (see Fig. 2-3), each curve is shown 
over a full work cycle of the engine, i.e. pressure [bar] versus crankshaft 
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angle [degrees], but is plotted relative to a common TDC so as to allow 
easy comparison with the other curves that are shown. 

With PV Diagrams, cylinder pressure is shown against the relative volume 
[%] of the cylinder, while with Balance Plots the Compression Pressure 
pcomp, Maximum Pressure pmax and Mean Indicated Pressure pi of all the 
cylinders are shown.

The PT and PV diagrams also include a tool panel. This enables you to 
switch 'On' and 'Off' the display grid, display cursor and the individual 
curves shown for each of the cylinders, simply by clicking on the corre-
sponding buttons with the mouse.

Similarly, by dragging the mouse over any portion of the pressure curves 
you can zoom in and obtain a magnified view of the area selected.

Fig. 2-3 A PT Diagram
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2.3.2 Calculated Values

Besides alternative graphic views for viewing measurements, information 
can also be obtained in tabular form. With both two and four stroke 
engines values for the Compression Pressure pcomp, Maximum Pressure 
pmax, Scavenge Air Pressure pscav and Engine Speed are given. In addition, 
the Mean Indicated Pressure pi and Effective Power, are given with two 
stroke engines.

Also stated for two-stroke engines, are calculated values for 'VIT', 'Shim' 
and 'ME' fuel pump adjustments. These indicate how much the index of 
each of the cylinders must be adjusted to get the engine properly balanced. 
Depending on the type of fuel pump the results are expressed as a change 
in “index”, “rotation of link”, “Shims to be added/removed’’ or as plain 
pressure adjustment values. 

2.3.3 Determination of TDC

The PMI System is designed to determine the TDC of the cylinders from a 
set of '0-Diagram' reference measurements. These measurements are usu-
ally made only once on a given engine when the PMI System is first 
installed. 

'0-Diagram' measurements are made by first letting the engine run at about 
50 to 75% load and then shutting off the fuel oil to the cylinder to be meas-
ured by setting its fuel pump index to zero or by disengaging the pump by 
lifting the roller gear. When the engine has stabilised, the pressure trans-
ducer is connected to the indicator cock of the cylinder and a measurement 
taken. See Installation Guide for further details.

2.3.4 Crankshaft Torsion Correction

A secondary factor which can influence the TDC's of an engine is the tor-
sional displacement or twisting experienced by each section of crankshaft 
due to the torque transmitted. 
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With the PMI System this is accounted for by taking an additional set of 
reference measurements at constant load. These are called 'E-Load' meas-
urements and differ from '0-Diagram' measurements in that a normal sup-
ply of fuel oil is maintained on all cylinders throughout the measurement.

The 'E-Load' measurement is then used together with the '0-Diagram' to 
calculate the correct TDC's of all the cylinders. The correction is made 
automatically for each cylinder and is based on the torsional coefficients 
specified in the PMI System's software. See Installation Guide for further 
details.

2.3.5 Cylinder Identification

A useful feature of the PMI System is that it automatically recognises and 
keeps track of which cylinders measurements are made on. It is therefore 
able to follow the progress of a measurement and indicate the exact order 
that the individual cylinders are measured, even when they are measured in 
a random order. In addition, it is able to inform about the number of meas-
urements made on each cylinder.

With four-stroke engines, it is necessary to start measurements with Cyl. 1, 
as otherwise the PMI System will not correctly recognise the order of the 
subsequent cylinders measured.

2.4 Supplementary Features

The Off-line PMI System has a number of additional features which are 
intended partly to make operation easier, and partly to ensure appropriate 
handling of data.

2.4.1 Standard PC Hardware

The PMI System's hardware and application software can be used on any 
standard IBM-compatible PC. Normally, the same computer as used for 
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other purposes in the engine control room can be employed, provided that 
it has a free communication port available.

2.4.2 Windows Display & Operation

The PMI System's display is built up on a standard Windows™ environ-
ment. Although some prior experience of using windows based computer 
applications is desirable, it is not strictly necessary. For the most part only 
rudimentary skills of using a PC are needed.

Like other Windows™ based software applications, its display includes 
pull-down and pop-up menus. These are used for choosing specific com-
mands and functions by selecting them with the mouse or via the keyboard 
of the PC.

Also, several toolbars are included. One of these is situated just below the 
main menu and is for quick access to the most frequently used commands 
that are available with the PMI System, while the other is located along 
side the measurement views that are presented and is used to select pres-
sure curves for each of the individual cylinders of a diesel engine.

2.4.3 On�line Help

Whenever using the PMI System a comprehensive on-line help feature is 
always immediately at hand. If in doubt about a particular operation you 
can press the F1 key at the top of the PC's keyboard in order to activate 
context sensitive help. This will display help information on screen about 
the particular command you are currently using.

You can also select one of the commands listed in the 'Help' menu. This 
enables you to search for information on any specific topic or to obtain 
instructions and advice on how to use a particular command.
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2.4.4 Data Backup

The PMI System features manual backup and restoration of its database 
which contains setup data, as well as data concerning cylinder pressure 
measurements.

With manual backup, backup copies are stored on the hard disk of your PC 
or can be transferred to standard data diskettes. These can then be used to 
restore the database if it becomes corrupted. In addition, backup copies 
can be sent to head office for keeping them up-to-date about the operating 
status of your diesel engine plant.

2.4.5 Use with Other Software

The PMI System can be used with a number of other software applica-
tions. 

For example, measurement data can be transferred from the PMI System 
to the CAPA Performance System or to the CoCoS-EDS Engine Diagnos-
tics System which are available from MAN B&W Diesel. 



Chapter 2 – Getting to Know the PMI System
Supplementary Features MAN B&W Diesel

Off�line PMI System 1142958 � 4.6
2 �12 User’s Guide



MAN B&W Diesel A/S Off�line PMI System
1142958 � 4.6 User’s Guide 3 �1

Chapter 3

Exploring the PMI System

This Chapter explains about operation and use of the PMI System. It pro-
vides basic details on the main window elements and commands which are 
available with the PMI System and shows you how to use it to obtain a 
clear overview of your cylinder pressure measurements. 

In this Chapter

• Starting the PMI System.............. 3 - 2

• The PMI Windows Environment 3 - 2

Main Window................................. 3 - 2

Mouse/keyboard Operation ............ 3 - 4

• Opening Engines........................... 3 - 5

• Opening Measurements ................ 3 - 6

• PT Diagrams.................................. 3 - 8

• PV Diagrams ............................... 3 - 11

• Balance Plots ............................... 3 - 12

• Calculated Values ........................ 3 - 14
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3.1 Starting the PMI System  

3.2 The PMI Windows Environment

For getting acquainted with the PMI System, the following sections 
explain the basic elements of its main window and the use of a mouse and 
keyboard to operate the system.

3.2.1 Main Window

Fig. 3-1 shows the main window of the PMI System. This is what you will 
see on the PC when you start the system. The appearance, layout and use 
of the main window are similar to that of other Windows™ software appli-
cations. 

The main elements of the window are:

Title bar:

This bar indicates the name of the particular software application which is 
being run, plus the particular diesel engine that is chosen for making new 
cylinder pressure measurements or viewing the results of earlier measure-
ments, i.e. PMI System – [Main Engine].

Menu bar:

This shows the names of the PMI's main menus. Clicking on the names 
with the left mouse button, lists the functions and commands that are avail-
able with each of these menus. Clicking on a command listed in the menu, 
activates the command.

PMI System

To start the PMI System use the mouse to double-click on the 'PMI Sys-
tem' icon contained on the windows desktop or on the corresponding pro-
gram listed in the 'Start' menu on your PC. 
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Note: Only those commands which are fully visible can be activated. 
They depend on the particular window and the command which you last 
activated.  

Toolbar:

This contains a row of buttons each marked with a function symbol. By 
using the mouse to slowly move the display cursor across the Toolbar, hints 
are flagged about the purpose of each button. Clicking on the buttons with 
the mouse provides quick access to the most frequently used commands 
which are also available using the Menu bar located just above the Toolbar.

Fig. 3-1. The primary elements of the PMI System's main window

Title bar

Menu bar

Toolbar

Status line
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As with the commands listed in the Menu bar, only those tool buttons 
which are fully visible can be activated. They depend on the particular 
window and the command or tool button which you last activated.

Status line:

A red 'OFF' or green 'ON' marker is flagged at the left-hand end of the sta-
tus line. A red marker indicates that the PMI System is working off-line, 
i.e. is not connected with the PMI Controller, while a green marker indi-
cates that it is checking connection and communication with the Control-
ler.

3.2.2 Mouse/keyboard Operation

The windows, dialogue boxes and commands included with the PMI Sys-
tem, are chosen in the same way as with other Windows™ based applica-
tions – by using the mouse or by keyboard short cuts.

For a concise explanation this and the following sections mainly concen-
trate on use with the mouse, but keyboard operations are explained wher-
ever practical. 

The terms used to explain the various actions which may be performed 
with the mouse, are as follows:

Click: Click the left mouse button

Right-click: Click the right mouse button

Double-click: Click the left mouse button quickly, twice in suc-
cession.

Drag: Select and highlight values or text in data fields or 
to define part of a curve to be magnified using the 
'Zoom' function. To do this, position the mouse 
cursor at the start of a display region of interest, 
press the left mouse button and while keeping the 
button pressed, move the cursor diagonally over 
the area of interest and release the button.
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The following keys emulate the function of the mouse:

Home: Steps to the start of a list or to the start of the first 
character in a data field. 

End: Steps to the end of a list or to the end of the last 
character in a data field.

Page Down: Steps to the bottom of a list.

Page Up: Steps to the top of a list. 

Arrow Up: Steps up to the next adjacent line in a list. 

Arrow Down: Steps down to the next adjacent line in a list. 

Arrow Left/Right: Step left or right to the next adjacent column in a 
list or character position in a data field. Keeping 
a key pressed, scrolls to left or right in a data field.

Shift + Arrow Key: Scroll the text cursor left or right or up or down in 
a data field, highlighting all characters and lines 
that it moves over.

Tab: Steps text cursor to the next data field, check box 
or command button in a selection dialogue.

Shift + Tab: Step to the previous data field, check box or com-
mand button in a dialogue.

Enter: Activates a command button selected in a dia-
logue.

Esc.: Cancels a command or closes a dialogue.

3.3 Opening Engines

Each time that the PMI System is opened from the Window's desktop or 
'Start' menu, it automatically selects the engine that was last selected dur-
ing previous use of the program. The name of the particular engine is indi-
cated in the title bar (see Fig. 3-1) of the main window. 
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With multi-engine plants, it is possible to choose other engines by select-
ing them with the 'Open Engine' command. This is contained in the 'File' 
menu and opens the dialogue shown in Fig. 3-2. To select the engine that 
you want to work with, left-click its name with the mouse and then click 
the 'Open' button. Alternatively, use the Up/Down arrow keys on the key-
board to select the name of the engine and then press the Enter key. 

3.4 Opening Measurements  

Fig. 3-2. The 'Open Engine' dialogue

 

After selecting an engine (see previous section), you can proceed to select 
one of the measurements which have been stored for the particular engine. 
Measurements are chosen using the dialogue shown in Fig. 3-3, which is 
opened by activating the 'Open Measurement' command in the 'File' menu 
or by clicking on the corresponding button in the toolbar.

 

Initially measurements are listed by just their designation, but further 
details can be obtained by clicking the 'Details' tool button near the top, 
right corner of the dialogue (see Fig. 3-3).

Alternatively, 'Details' may be selected using the quick-access menu shown 
in Fig. 3-5, which is opened by right-clicking anywhere in the 'Open Meas-
urement' dialogue.
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Measurements are opened by selecting them either with the mouse or with 
the arrow and enter keys on the keyboard. Opening a measurement, dis-
plays its pressure versus time curve, i.e. 'PT diagram' view, which is 
explained in the following section. 

Fig. 3-3. The 'Open Measurement' dialogue

Fig. 3-4. The 'Open Measurement' dialogue as viewed with the 'Details' 
function
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3.5 PT Diagrams

A 'PT Diagram' is shown in Fig. 3-6 and can contain pressure curves for up 
to 24 cylinders, depending on the number measured. Each curve is shown 
over a full work cycle of the engine, i.e. pressure [bar] versus crankshaft 
angle [degrees], but is plotted relative to a common TDC so as to allow 
easy comparison with the other curves that are shown. Also, each curve is 
plotted with a separate colour, in order to help distinguish between them.

As a reminder, a “No 0-Diagram Data” message is displayed whenever 
measurements are opened which do not include a '0-Diagram' reference 
measurement. See section 4.2 for details about editing measurements and 
linking them with 'O-Diagram' measurements. 

PT Tool Panel: 

The PT Diagram is equipped with a Tool Panel (see Fig. 3-7). This is 
located on the right-hand side of the display screen and can be used to acti-
vate or de-activate various elements of the diagram. For example, you can 
toggle 'On' and 'Off' the display grid, display cursor and the individual 
curves shown for each of the cylinders, simply by clicking on the corre-
sponding buttons.  

Fig. 3-5. The quick-access menu which is availa-
ble by right-clicking the mouse in the 
'Open Measurement' dialogue

A PT Diagram is displayed immediately on opening a measurement with 
the 'Open Measurement' command (see previous section). Alternatively, 
you can select a PT Diagram either by selecting it in the 'View' menu or by 
clicking on the corresponding button in the Toolbar.
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Fig. 3-6. A PT Diagram

Fig. 3-7. Control Panel of the PT diagram

Grid 
On / Off

Cylinders

Cursor 
On / Off

Zoom Out
to 100%

View
Cylinder/Engine
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Also, by using the mouse to move the display cursor across these buttons, 
you can obtain hints about the purpose of each button.

Display Grid:

Display Cursor:  

Zoom Function:

If you want to examine diagrams in more detail you can zoom in and mag-
nify any portion of the diagrams as shown in Fig. 3-8. 

To zoom in on part of a diagram, position the mouse cursor at the start of 
the region of interest on the display. Next press the left mouse button and 
while keeping the button pressed, drag the cursor diagonally over the area 
of interest and release the button. This will magnify the area. 

Cylinder / Engine View:    

To switch on the 'Display Grid', click the button shown. The grid is active 
when the button is depressed.

When the 'Cursor' button is activated (i.e. button depressed), you can move 
the cursor up or down, or to the left or right by pressing the appropriate 
arrow key on the keyboard. Also you can step from one curve to the next 
simply by aligning the cursor on a raised portion of the curve and pressing 
the up or down arrow key. The selected cylinder and cursor position are 
indicated at the bottom of the display.

When you want to return to the original view, press the 'Zoom' button in 
the tool panel to deactivate it. 

 

This button is only active when a measurement contains more than one 
observation per cylinder. Press the 'Cylinder View' button 'C' to switch to 
the 'Cylinder' display mode or press the 'Engine View' button 'E' to switch 
to the 'Engine' display mode.
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3.6 PV Diagrams 

In the 'Cylinder' mode (i.e. button in inner position) all observations of the 
selected cylinder are shown in one view, while in the 'Engine' mode (i.e. 
button in outer position) only one observation per cylinder of all cylinders 
is shown in one view, i.e. the last observation made on each cylinder.

Fig. 3-8. Zooming-in on a PT Diagram

A 'PV Diagram' is shown in Fig. 3-9 and can be displayed either by select-
ing it in the 'View' menu or by clicking on the corresponding button in the 
Toolbar.
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The 'PV Diagram' shows the cylinder pressure [bar] as a function of the 
relative volume [%] of the cylinder. The area contained by the curve is pro-
portional to the work done during the work cycle.

As with the PT Diagram, the PV Diagram is equipped with a Tool Panel. 
This also has buttons for toggling the display grid, display cursor, zoom, 
etc., which function in precisely the same manner as described earlier for 
the PT Diagram. See section 3.5.

3.7 Balance Plots   

Fig. 3-9. A PV Diagram

Also included in the 'View' menu is the 'Balance Plot' command. This pro-
vides a bar chart presentation of the combustion pressures of the respective 
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A typical 'Balance Plot' is shown in Fig. 3-10. The compression pressure 
pcomp, the maximum pressure pmax and the mean indicated pressure pi of the 
cylinders are shown and can be individually toggled 'On'/'Off' or 'Off'/'On' 
by clicking on the corresponding buttons provided on the right-hand side 
of the display.

On the left of the display is given the mean pressure (i.e. arithmetic aver-
age of the individual cylinder pressures combined), while on the right of 
the display the difference between the actual pressure measured and the 
mean pressure (i.e. deviation from mean) is indicated for each cylinder. 

cylinders of an engine and therefore is a useful indicator of the cylinder 
pressure distribution or balance of the engine.

Fig. 3-10. A Balance Plot
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3.8 Calculated Values

The schemes give values for the Compression Pressure pcomp, the Maxi-
mum Pressure pmax and the Speed for four and two stroke engines. The lat-
ter cover two stroke engines with 'Shim', 'VIT' and 'ME' adjusted fuel 
pumps and also gives the Mean Indicated Pressure pi, the Scavenge Air 
Pressure pscav and the Effective Power for such engines, plus the pcomp/
pscav ratio for the 'ME' type  

With 'VIT' and 'Shim' adjusted fuel pumps the results are expressed as an 
'Index Adjustment' (i.e. change of index), as well as in terms of a 'Rotation 
of link' (i.e. the number of turns required to obtain a certain displacement 
of the rod) or the number of shims to be inserted or removed.

Selecting the 'Calculated Values' in the 'View' menu, opens display 
schemes similar to those shown in Fig. 3-11 and Fig. 3-12. The same 
schemes can also be opened by clicking the 'Calculated Values' button in 
the Toolbar. 

Fig. 3-11. A 'Calculated Values' scheme for a four stroke 
diesel engine

Also, included in the two stroke engine schemes are calculated values for 
fuel pump index adjustments. These show how much the index of each of 
the cylinders must be adjusted to get the engine properly balanced and are 
selected by clicking on the 'Index Adjustments' button at the top of the tool 
panel of the schemes.
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In contrast with 'ME' pumps, calculated values for p(i), p(max) and 
p(comp)/p(scav) adjustments are given for direct entry on the main operat-
ing panel of the engine. To obtain details about these adjustments, a 
p(scav) value must be keyed in with the 'Edit Measurement' dialogue. See 
Fig. 4-7.

To help you assess the effect of the above adjustments on the mean indi-
cated pressure pi and mean maximum pressure pcomp of the engine before 
actually applying them, the calculated 'Mean' and 'New Mean' pressures 
are listed directly above one another.  

Fig. 3-12. A 'Calculated Values' scheme for a two stroke 'ME' diesel 
engine. 'Index Adjustments' can be viewed by pressing a tool 
panel button and moving the scheme with the scroll bar
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Chapter 4

Pressure Measurements

This chapter explains how to make pressure measurements with the PMI 
System. Also details are given about how to edit and delete measurements, 
as well as how to backup and restore the measurement database of the sys-
tem.

In this Chapter

• Making Pressure Measurements . 4 - 2

• Checking & Editing                                      
Measurements ................................ 4 - 4

• Deleting Measurements ............... 4 - 8

• Backing Up & Restoring                            
the PMI Database.......................... 4 - 9
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4.1 Making Pressure Measurements

For making pressure measurements on two and four stroke diesel engines, 
the PMI System should be used as follows:  

The main window of the PMI System should now appear as indicated 
in Fig. 3-1. 

2. Check that the correct engine is shown in the title bar of the main win-
dow.

If not, open the engine by selecting 'Open Engine' in the 'File' menu and 
select it in the dialogue which is opened. 

3. Select 'Communication On' in the Tools menu.

The PMI Program will now check communication, but the result of this 
check can be ignored at this stage as the PMI Controller has not yet been 
connected.  

The view in Fig. 4-1 will now appear which shows a series of panels, 
one for each cylinder of the engine. 

Initially, the panels are coloured grey, but change to green after meas-
urement on the corresponding cylinders has been completed. In addi-
tion, the number of observations made on each cylinder is indicated on 
the panels.

5. Connect the Pressure Transducer to the PMI Controller and the 
multipole plug of the PMI Controller to the Junction Box. See Fig. 2-2 
and Fig. 4-2.   

Caution: Always connect the Pressure Transducer to the PMI Con-
troller before connecting the Controller to the Junction Box. Con-
necting the Transducer while powering the Controller can damage 
the Controller.  

PMI System

1. Switch on the PC and start the PMI Program by clicking on the PMI 
System icon on the windows desktop. 

 
4. Select 'Measure Status' in the 'View' menu or the corresponding tool in 

the toolbar.
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6. Wait until the engine is running with a even load and is stable.

The PMI System is ready for measurements when the green light on the 
PMI Controller begins to flash repeatedly.

7. Mount the Pressure Transducer on the indicator cock of Cylinder No. 1 
and open the indicator cock.

Fig. 4-1. The 'Measurement Status' view

Fig. 4-2. The top panel of the PMI Controller box.

Power
'On'

Start
Ready

Cancel
Error

PMI
Transducer

Green
Indicator

Green
Button

Red
Button
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Note: When measuring on four stroke engines it is important to 
start with cylinder No. 1 to ensure correct identification of each 
cylinder by the system.

8. Press the green 'Start' button on the PMI Controller to start the meas-
urement.

When the green light lights again, the measurement will have been com-
pleted.

9. Close the indicator cock and remove the Pressure Transducer. 

 Warning: Always check that the indicator cock is closed 
before removing the transducer. Failure to do this can result in 
release of extremely hot combustion gasses which can severely 
injure personnel.

10. Repeat steps 7 to 9 until you have completed measurements on all cyl-
inders.

11. Return to the PC and stop measurements by pressing Esc. on the key-
board or by selecting 'End Measurement' in the 'Tools' menu.

Alternatively, you can stop measurements by unscrewing the multipole 
plug of the PMI Controller from the Junction Box. This is useful if you 
want to make another set of measurements before returning to the PC. 
To be able to do this it is important that you unscrew the plug only when 
the green 'Start' button is lit and that you wait at least 10 seconds before 
reconnecting the plug.

Stopping measurements automatically stores them in the PMI System's 
database. 

4.2 Checking & Editing Measurements

On completing one or more sets of pressure measurements, the measure-
ments should be inspected using the 'Open Measurement', 'Edit' function. 

To do this, proceed as follows:   

 
1. Activate 'Open Measurement' in the 'File' menu.

!
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Fig. 4-3. The 'Open Measurement' dialogue as viewed with the 'List' 
function

Fig. 4-4. The quick-access menu which is
available by right-clicking the mouse
in the 'Open Measurement' dialogue

Fig. 4-5. The 'Open Measurement' dialogue as viewed with the 
'Details' function
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This opens the 'Open Measurement' dialogue shown in Fig. 4-3 which 
lists all the measurements made with the PMI System. 

The most recent pressure measurements are listed with the prefix 'm' 
and have the date and time of storage as part of their designation.

e.g. m990124_102730.      

Activating 'Observations' opens the 'Edit Cylinder Observations' dia-
logue shown in Fig. 4-6. 

By clicking on the '+/-' symbol shown at the start of each cylinder head-
ing you can expand or contract a heading. 

 

To view details about the measurements (see Fig. 4-5), right-click any-
where in the dialogue to actuate its quick-access menu and then select 
'Details' (see Fig. 4-4). Alternatively, click on the corresponding button 
in the dialogue's toolbar. 

 
2. Select the particular measurement that you want to examine by left-

clicking its name with the mouse and then activate the 'Observations...' 
command in the quick-access menu or click the corresponding button 
in the dialogue's toolbar. 

Fig. 4-6. The 'Edit Cylinder Observations' dialogue
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To examine an observation, click on its heading. Its pressure curve is 
then displayed on the right-hand side of the dialogue.

3. Check the observations listed for each cylinder of the engine.

If more than one observation is available per cylinder, it is possible to 
delete those which are not needed by selecting them and pressing the 
'Delete' button at the bottom of the 'Edit Cylinder Observations' dia-
logue. See Fig. 4-6. 

Activating the 'Edit' command opens the 'Edit Measurement' dialogue 
shown in Fig. 4-7. This allows you to rename the measurement as well 
as to check whether the measurement is linked with the appropriate '0-
Diagram' and 'E-Load' reference measurements.  

5. To rename the measurement, click in the measurement field and key in 
a new name.

For this purpose a naming convention which preserves the date and time 
of the measurement is suggested. 

e.g. m_70_990124_1055

Where the first character 'm' indicates a measurement, the next three 
characters indicate the engine load, the next seven characters the date 
and the last five characters the time that the measurement was stored. 

6. Next check that the names of the appropriate '0-Diagram' and 'E-Load' 
measurement files which are to be used for TDC determination, appear 
in the list-boxes immediately below the name of the measurement. 

If no '0-Diagram' and 'E-Load' files are listed, then the appropriate 
measurements must be made as explained in the “Commissioning” 
Chapter of the Installation Guide for the PMI System.

7. Finally, key in the appropriate value for the scavenge air pressure of the 
engine in the 'p(scav):' data field and press the 'OK' button to close the 
'Edit' dialogue and save your changes to the measurement.

 
4. Next click the 'Close' button to return to the 'Open Measurement' dia-

logue and then activate the 'Edit' command in the dialogue's quick-
access menu or click the corresponding button in its toolbar.
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Note: If no scavenge air pressure reading is keyed in, then the pro-
gram itself will automatically estimate it. To force estimation the 
'p(scav):' data field must be set to '0' or '0.00'.

After having checked and accepted a measurement as described above, it 
may be examined in more detail using the 'View' menu commands which 
are explained in section 3.5 to 3.8.

4.3 Deleting Measurements

Fig. 4-7. The 'Edit Measurement' dialogue

 To delete measurements which are no longer needed, the 'Open Measure-
ment' command in the 'File' menu includes a 'Delete' function. This may be 
activated either by clicking on the tool button shown or by selecting the 
command in the dialogue's quick-access menu. 
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4.4 Backing Up & Restoring the PMI Database

For optimum security, we recommend that you frequently take a backup 
copy of the PMI database to help safeguard your measurement data. For 
this purpose a backup copy can be saved on the hard disk of your PC using 
the dialogue shown in Fig. 4-8.

The 'Backup' dialogue is opened using the 'Backup' command in the 'File' 
menu. To commence backup, click on the 'Make' button. The PMI System 
then responds with the name and location of the new file which is to be 
used for storing the backup on your hard disk. To accept the file and con-
tinue with backup, click on the 'Yes' button. The PMI System then takes a 
copy of database and stores it on the hard disk. 

In addition to the above, the 'Backup' dialogue has functions for restoring 
the PMI System database and deleting backup files, as well as saving and 
getting them from elsewhere, such as on floppy disks or other external 
media. These functions are included on the 'Restore' and 'Catalogue' tabs 
of the 'Backup' dialogue (see Fig. 4-9 and 4-10). When backup files are 
created they are stored in compressed form and are automatically decom-
pressed whenever they are used to restore the PMI System's database.   

Fig. 4-8. The 'Backup' dialogue
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Note: When restoring the database it is important that the appropriate 
backup file is selected (i.e. is highlighted) in the 'Backup > Restore' di-
alogue.

Restoring data files from a backup copy of the data base will overwrite 
existing data. Therefore to reduce the risk of losing recent measure-
ments and other data, always take a backup copy before attempting to 
restore the data base.

Fig. 4-9. The 'Backup > Restore' dialogue

Fig. 4-10 The 'Backup > Catalogue' dialogue
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Chapter 5

PMI Menus & Commands

This Chapter provides a brief overview of the commands and other func-
tions which are available with the menu bar of the PMI System and 
includes reference to keyboard shortcuts and toolbar buttons.

In this Chapter

• File Menu....................................... 5 - 2

• View Menu..................................... 5 - 2

• Tools Menu .................................... 5 - 3

• On-line Help .................................. 5 - 4

Help Menu ...................................... 5 - 4

Function Key F1 ............................. 5 - 5
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5.1 File Menu

• Open Engine ...: Opens the 'Open Engine' dialogue for selecting spe-
cific engines for pressure measurements and viewing measurement 
results. See section 3.3 for further details. 

• Close Measurement: Closes the current measurement view leaving 
the currently selected engine open.

• Backup...: Opens the 'Backup' dialogue for making a backup copy of 
the PMI System database on the hard disk of your PC. It is also used 
for restoring the PMI System database and for archiving/cataloguing 
files. See section 4.4 for further details.  

• Print Setup ...: Opens the 'Print Setup' dialogue for selecting printer, 
printer properties, page orientation, page size and other page set-up 
options. 

• Exit: Closes the PMI System.

Shortcut: 'Exit' can also be chosen using Alt. + F4.

5.2 View Menu    

• Open Measurement ...: Opens the 'Open Measurement' dialogue for 
selecting 'All', 'New' and 'Old' measurements for the particular engine 
chosen with the 'Open Engine' command specified above. See 
section 3.4 for further details.

Shortcut: 'Open Measurement' can also be chosen using Ctrl. + O.

• Print: Prints the content of the window which is currently activated. 

Shortcut: 'Print' can also be chosen using Ctrl. + P.

 

• PT Diagram: Displays the PT Diagram of current engine, i.e. the cyl-
inder pressure versus time (i.e. crankshaft angle) diagram. See 
section 3.5 for further details.
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5.3 Tools Menu
• Communication: For enabling (' ' mark beside menu item) and dis-

abling communication between the PMI program and the PMI Control-
ler. If the program fails to establish communication, then it is automat-
ically set 'Off-line' for viewing stored measurements. See section A.4.

• Test System: Checks communication to the PMI Controller and tests 
the trigger system. See section A.4.3.

• Start Measurement: Checks communication with the PMI Controller 
and starts the measurement sequence if the PMI Controller is con-
nected.

• End Measurement: Stops measurement. 

• Communication Log...: Opens the 'Communication Log' which keeps 
a record of all communication checks made between the PMI System 
and the PMI Controller.

• Options ...: Opens the 'Options' dialogue for setting up communication 
port, transducer calibration, measuring period and single or double 
triggering. See section A.4.1. 

 

• PV Diagram: Displays the PV Diagram of current engine, i.e. the cyl-
inder pressure versus relative volume diagram. See section 3.6 for fur-
ther details.

 

• Balance Plot: Displays the balance plot of the mean pressure, as well 
as the difference between the actual pressure measured and the mean 
pressure indicated for each cylinder. See section 3.7 for further details.

• Calculated Values: Displays a list of calculated measurement values 
for all cylinders. Also includes proposed values for Index Adjustment. 
See section 3.8 for further details.

 

•  Measuring Status: Indicates the current status of each measurement, 
as well as the cylinder order and number of measurements performed. 
See section 4.1 for further details.
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• TDC Values ... : Displays the crank angle offset plus measured crank 
angles corresponding to the TDC of the respective cylinders. For dis-
play select the latest '0-Diagram' measurement for the current engine 
from the opening dialogue. The crank angles are stated in radians and 
degrees.

5.4 On-line Help

The PMI System provides several ways of getting 'On-line Help'. You can 
use either the 'Help' menu or the function key F1. 

5.4.1 Help Menu 

To help you determine which menu commands are used to access specific 
topics, the respective menu commands are listed below: 

• Using Help: How to use the Windows Help System together with 
the PMI System's 'On-line Help'. Also, includes Windows Help 
Index and search engine for finding specific topics.

• Screen: The PMI System screen structure, including definitions of 
its main components.

• Commands: The PMI System commands, keyboard and mouse 
functions, menus and toolbar.

• Tools: The function of the different buttons seen in the 'Toolbar' of 
the PMI System.

• How to...: The operating instructions for using the PMI application 
software and hardware. 

• Contents: Displays the 'Help Contents'. This is the most detailed 
source of information and clicking on the respective items listed pro-
vides information on the following topics:
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• Keyboard: The keys and key combinations associated with the 
PMI System commands.

• Glossary: A glossary explaining the PMI System and other related 
terms.

At the top of the 'Help Contents' window is a row of five keys. These 
select the following:

• Help Topics: Opens the 'PMI Index and Find' dialogue, enabling 
you to search for and display any topic by keying in its name or by 
clicking on a topic listed in the dialogue.

• Back: Returns the 'Help' window to the previous view or topic.

• Print: Prints the current view or topic.

• Glossary: Lists a 'Help Glossary', explaining about the PMI Sys-
tem and other related terms.

• Close: Exits the 'Help' window.

The remaining commands contained in the 'Help' menu are as follows:

• Search for Help On...: Opens the 'Index and Find' dialogue for finding 
specific topics about the PMI System.

• How to Use Help: How to use PMI System's 'On-line Help'. For exam-
ple, how to find, copy and print information, as well as customise help.

• About ...: Displays the name, version and build number, as well as 
copyright information concerning the PMI System software which is 
installed on your PC. Also information is provided about where and 
how to get product support: on-line, in printed documentation or by 
contacting MAN B&W Diesel.

5.4.2 Function Key F1

Whenever in doubt about any command or function that you are using, 
press the Function Key F1 at the top of the keyboard. This will immedi-
ately provide you with context sensitive help information about the partic-
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ular command or function that you are using in the particular situation that 
you are using it.

To access context sensitive information about a menu item, you can use 
either the keyboard alone or the mouse together with the keyboard. 

To use the keyboard, first press the 'Alt' key and the first letter of the main 
menu that you wish to examine, and then use the arrow keys to select the 
particular command of interest in the menu and press the 'F1' key to acti-
vate context sensitive help.

If you use the mouse, click on the name of the main menu and while keep-
ing the mouse button pressed, select the command of interest and press the 
function key 'F1' on the keyboard.

Note: Keep the mouse button pressed until you have activated the 'F1' 
key. 

Similarly you can also get context sensitive help on other items displayed 
in the main window, e.g. views, menus, dialogues, etc. In addition, by 
pointing the mouse at the buttons in the Toolbar you can obtain hints about 
the purpose of the individual buttons. These are flagged just below each 
button and explain what will happen when you click on a tool. 
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A.1 Technical Specification

A.1.1 Off�line PMI System
Engine Types: 

All two & four stroke MAN B&W diesel engines with up to 24 Cylinders

Engine Speed:
Up to 900 rpm

Pressure Range:
 0 to 225 bar

Measurement Modes:
PT, PV and Balance Diagrams giving Mean Indicated Pressure pi and Maximum Pressure 
pmax deviation limits

Calculated Values:
Two-stroke: Effective Power, Mean Indicated Pressure pi, Compression Pres-

sure pcomp, Maximum Pressure pmax, Scavenge Air Pressure 
pscav, Index Adjustments, etc.

Four-stroke: Compression Pressure pcomp, Maximum Pressure pmax and 
Scavenge Air Pressure pscav

Overall Accuracy:
± 3%

Repeatability:
± 1%

PC Software:
CD-ROM 

System Hardware: 
Pressure Transducer
PMI Controller
Junction Box
Intermediate Box
Converter Box
TDC & Crank Angle Pickups: Angle Encoder

Light Emitting Pickup
or Proximity Detector Pickup

Power Requirements:
Supply Voltage: 24 V DC nominal (18 to 32 V)
Consumption: 800 mA

Operating Temp.: 
PMI Controller: 50°C max.
Transducer: 350°C max. short term use

Mass:
PMI Controller: 3.15 kg including cable
Transducer: 0.72 kg including adaptor
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A.1.2 Computer Requirements

Hardware:

To obtain full advantage of the PMI System and its many features, MAN 
B&W Diesel recommends the following minimum system configuration:

• IBM PC or 100% IBM compatible computer

• Pentium II Processor, or later

• 32 MB RAM

• Hard disk with 500 MB free space available

• SVGA video adaptor

• CD-ROM drive

• Floppy drive for 3.5 inch HD (1.44 MB) diskettes

• Mouse

• 17 inch SVGA Colour Monitor

• Printer

• Free Com. Port – 1, 2, 3 or 4

Software:

• Microsoft® Windows NT 3.5.1, Windows 95™ or later

A.2 Software Installation

The PMI software is normally supplied on a CD, containing both the PMI 
application program and engine specific data concerning your diesel 
engine plant.

To install the PMI program and its data:

1. Insert the CD in your CD-ROM drive.
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2. Open the 'Start' menu in the bottom left corner of the display and 
choose 'Run'.

3. Type d:\setup.exe. (If your CD-ROM Drive is not letter D, type the 
appropriate letter instead.)

4. Select OK.

5. Follow the instructions on screen.

With WIN NT 3.5.1, WIN95, or later, the installation software will auto-
matically install a 'PMI System' icon on the Window's desktop for opening 
the program. In addition, it will be listed in the programs menu and sub 
folder contained in the 'Start' menu.

A.3 Care & Handling of Equipment

The PMI System uses a high performance pressure transducer which is 
recognised for its excellent performance and stability in a wide variety of 
environments where relatively high levels of mechanical vibration as well 
as temperatures up to 350°C exist. However, like other measurement 
devices it should be handled with care in order to preserve its measure-
ment performance and accuracy. Therefore, whenever using the transducer 
and associated equipment, always heed the following: 

• Storage: 

When not in use the transducer should be returned to its original pack-
aging and stored at room temperature (~20°C). In addition, its output 
connector should be fitted with the plastic protection cap provided. 

• Handling: 

Avoid hitting or dropping the transducer as this can subject it to me-
chanical shock well outside its design limits and can severely damage it.

• Mounting:

Avoid over tightening the transducer when mounting it on the cylinder 
indicator cock. Always tighten it by hand without using a spanner. Also, 
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only open and close the indicator cock whilst the transducer is connect-
ed and always remove the transducer immediately after completing 
each measurement. 

Warning! Leaving the transducer permanently mounted on the 
indicator cock will severely damage it.

• Connections:

The output connecter of the transducer, including the corresponding 
plugs and sockets of the connecting cable and the PMI Controller, 
should be kept clean and free of oil and grease at all times. When not in 
use they should be fitted with the plastic protection caps provided.

The multipole connector used to couple the PMI Controller to the Junc-
tion Box should be treated with care. Whenever plugging or unplugging 
it from the Controller, it is important to turn the outer part of the con-
nector so as to lock or unlock it from the Controller. Avoid using tools 
on the connector.

If the connectors need cleaning, then only use dry, chemically clean, 
pressurised air, such as that used for cleaning photographic equipment.

Caution: Never use compressed air from ship or generator plant 
outlets as they contain oil. Similarly, avoid using chemical cleaning 
agents, as they will damage the ultra high impedance insulation of 
the connectors and cable. 

• Calibration:

Where the pressure transducer is subjected to frequent handling as when 
used for regular performance measurements and surveys on diesel en-
gine plant, we recommend that it is checked and recalibrated every 12 
months. Also if at any time the transducer appears to have been physi-
cally damaged in any way or that there is partial or complete loss of out-
put signal from the transducer, then it should be replaced and the PMI 
System readjusted in accordance with the sensitivity of the new trans-
ducer. See section A.4.1 below.

Important Note: Where the PMI System is used for onboard sur-
veys in connection with the ''IMO – NOx Technical Code'', it is the 
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responsibility of the operator to ensure that the apparatus (sensors 
and gauges) are correctly adjusted and calibrated in accordance 
with the manufacturers instructions. For details, please refer to the 
''IMO – NOx Technical Code''.

A.4 System Checks

If the PMI System fails to establish communication with the particular 
engine that is selected, then it is likely that the appropriate communication 
options have not been chosen or that the engine's address setting is incor-
rect. 

A.4.1 Communication Options

Communication between the software and hardware of the PMI System is 
set up using the 'Options' dialogue shown in Fig. A-1. This dialogue is 
opened by selecting the 'Options' command in the 'Tools' menu and should 
be set as follows: 

Communication Port: 1, 2, 3 or 4, depending on which port of the PC is 
coupled to the Converter Box of the PMI System.

Fig. A-1 'The 'Tools' menu 'Options' dialogue
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Calibration Factors: 'Transducer Value' – The transducer sensitivity at 
20 -  23 C and 250 bar, as specified on the cali-
bration chart supplied with the transducer.

'System Value' – A fixed value of 0.95 matching 
the system amplification of the Off-line PMI Sys-
tem.

Measuring Settings: ‘Averaging Period' – Sets the number of work cy-
cles over which the measurement is averaged. 
Should normally be set for averaging over 10 
work cycles.

'Single Trig.' – Normal setting for triggering with 
an Angle Encoder.

'Double Trig.' – Normal setting for other pickups.

A.4.2 Engine Address

Fig. A-2 'The 'Open Engine > Edit' dialogue

°
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The engine address is shown at the top of the 'Open Engine > Edit Engine 
Data' dialogue.   

The engine address number should match the SW1 address switch setting 
in the Junction Box for the engine to be measured – see Fig. A-11. 

If they do not match, change the dialogue's address number accordingly. 
Normally, the engine address should be set as follows: 

• always '0' for first engine

• '1', '2', ‘3', etc. for the second and subsequent engines, irrespective 
of whether they are two or four stroke.

If after checking the above, the PMI System still fails to communicate with 
the PMI Controller then it is recommended to check all plug and cable 
connections en route to the particular engine. See Installation Guide for 
further details.

For an explanation about other data fields included in the 'Open Engine - 
Edit' dialogue, see the 'Glossary' at the back of the User's guide.

A.4.3 Trigger Test

On completing communication test, the PMI System automatically starts a 
Trigger and TDC Test. If stable triggering cannot be achieved, then the 
PMI System will automatically warn about the situation by displaying the 
'Trigger and TDC Test' dialogue shown in Fig. A-3.

The test results indicated by this dialogue are as follows: 

• No. of pulses detected: This provides a count of the number of crank 
angle pulses detected per work cycle. 

When triggering is stable only one count will be displayed.

 
To view this dialogue, first select 'Open Engine' in the 'File' menu and 
click on the name of the particular engine concerned. The 'Edit' dialogue is 
then opened by clicking on the appropriate tool button at the top of the 
'Open Engine' dialogue.
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If triggering is unstable, then the latest five counts will be listed. See be-
low to help determine the cause.

• No. of pulses stored for engine: The crank angle pulse count that was 
obtained when triggering was last stable. 

• Pulse deviation (min./max): Gives the minimum and maximum per-
centage deviation of the crank angle pulses relative to their mean repe-
tition time.

Fig. A-3 The 'Trigger and TDC Test' dialogue

Fig. A-4 The 'Trigger Deviation' dialogue
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Large deviations indicate a dirty pickup or a defective trigger system. 
See section A.5.1 through to A.5.3. 

To obtain a graphic view of the trigger pulse deviation, click on the 'Dis-
play' button in the dialogue. See Fig. A-4.

• TDC pulse relative to trigger pulse: Indicates relative position of the 
leading edge of the TDC pulse with respect to the start and end of the 
crank pulse period (see Fig. A-5). For correct synchronisation the lead-
ing edge must be positioned between 15 and 85% of the crank pulse 
period.

If either of the readings is less than 15% or greater than 85%, then the 
pickup is not correctly adjusted or is defective. See section A.5.1 
through to A.5.3, which ever is appropriate for the type of pickup. 

Repeating the Trigger Test:

To repeat the Trigger Test, click on the 'Repeat' button in the dialogue.

Storing Trigger Test Count:

When testing has been completed and the system has been cleaned or re-
adjusted to provide stable trigger pulse count, click on the 'Save' button in 
the dialogue. This will store the pulse count for use in subsequent trigger 
tests. 

Fig. A-5 Timing of the TDC and Crank Angle Pulses

TDC Pulse

Crank Angle Pulses

A
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For multi engine plants, repeat section A.4.1, A.4.2 and A.4.3 to check 
communication and triggering with the other engines. 

A.5 Maintenance Checks & Adjustments

A.5.1 Angle Encoder

Fig. A-6 Mounting of the Angle Encoder

3 x Clamps and
M3 Hex. Socket Screws

M6 Hex. 
Socket Screw

6 x Hex. Screws

Shaft

Angle 
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Flexible
Coupling

Intermediate
Shaft

Housing with
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In installations which employ an Angle Encoder for crank angle triggering, 
the following checks and adjustments should be made if the PMI System 
fails to trigger correctly: 

• TDC Pulse Synchronisation: 

1. Engage the turning gear and turn the engine until cylinder No. 1 is at 
TDC as indicated on the turning wheel.

The green indicator light should now be lit on the Intermediate 
Box. If not, carry out steps 2 to 5 below. 

2. Loosen the 3 x M3 hexagonal socket head screws, clamping the Angle 
Encoder to the Cylindrical Housing at the free end of the crankshaft. 
See Fig. A-6.

3. Turn the encoder housing by hand, until the green light is lit on the 
Intermediate Box.

4. Tighten the 3 x M3 hexagonal socket head screws on the Angle 
Encoder. See Fig. A-6.

5. Check that the green light remains lit. If the light is off, repeat steps 2 
to 5 until it remains lit. 

• Engine Vibration: 

Check that the crankshaft cover is firmly mounted on the engine and that 
the cover does not vibrate excessively. If the cover vibrates, a number of 
metal ribs should be welded on the cover to stiffen it.

• Removal and Replacement: 

If any part of the Angle Encoder assembly or crankshaft cover have to be 
removed for any reason, then the entire assembly must remounted and 
adjusted again as described in the Installation Guide.

 Warning: To avoid injury, shut off the engine and block the start-
ing mechanism before attempting to remove or replace the Angle En-
coder. 

!
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A.5.2 LE�Pickup 

In installations using an LE-Pickup with Zebra Tape for TDC and crank 
angle triggering, the following checks and adjustments should be made if 
the PMI System fails to trigger correctly:  

Fig. A-7 Mounting of LE-Pickup on Adjustable Bracket. Certain parts 
may differ in design and appearance to suit the application

1. Apply the following safety precautions: 

• Stop the engine

• Block the starting mechanism

Zebra Tape Pickup Box 4 x M10 Hex. Socket
Head Screw

M8 Hex. Set Screw
with Cup Point

2 x M10 Hex. Head
Screws + Nuts

Support 
Bracket

(Not Supplied)

Mounting
Flange

Spring
Pins

Top Plate

2 x M10 Hex. Socket
Head Set Screw

!
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2. Check that the Zebra Tape which is bonded to the drive shaft is not 
contaminated by dirt, oil and grease. Clean the surface of the tape 
using a dry, absorbent cloth. 

Caution: Do not use cleaning agents containing chemical solvents 
or detergents, as these can dissolve the zebra tape, damaging its sur-
face and bonding properties.

3. Check that the pickup is firmly supported and is properly aligned with 
respect to the stripes on the zebra tape. There should be a clearance of 
2 mm between the tips of the pickups and the zebra tape. See Fig. A-7 
and A-8 respectively. 

4. Check that the LE-Pickup projects two dots of red light on to the zebra 
tape and that the indicator light on the Intermediate Box continuously 
flashes when the engine is started and is running stably.

• Shut off the starting air supply

• Engage the turning gear

Fig. A-8 Alignment of zebra tape and light dots from the LE-Pickup

Direction of Rotation

Marking

WrongCorrect

Cyl. No.1
at TDC
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If no light is visible, check the cabling of the PMI System and the ad-
justment of the amplifiers in the LE-Pickup Box – see Mounting and In-
stallation Guides for details. 

A.5.3 PD�Pickup 

In installations which use PD-Pickups for TDC and crank angle triggering, 
the following checks and adjustments should be made to obtain correct 
triggering: 

2. Check that the Pickup Box is firmly fastened and is aligned so that the 
respective pickups are centred over the teeth of the trigger ring and the 

Fig. A-9 Typical PD-Pickup mounting arrangement 1.5 to 2 mm from 
the teeth of a trigger ring and TDC marker bolted on the ring

1. Apply the following safety precautions: 

• Stop the engine

• Block the starting mechanism

• Shut off the starting air supply

• Engage the turning gear

Trigger Ring

Crank Angle
Pickup

TDC
Pickup

PD�Pickup Box

TDC
Marker
Plate

1.5 � 2 mm

!
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TDC marker bolted on the ring. Also, check that there is 1.5 to 2 mm 
clearance between the tip of each pickup and the teeth of the trigger 
ring or marker. See Fig. A-9. 

3. Remove the lid of the Pickup Box and check that the indicator lights at 
the back of the pickups repeatedly flash while the engine is running. If 
they do not flash, then there is either too little or too much clearance 
between them and the trigger ring or turning wheel, or they do not 
function correctly and should be replaced. 

For further information about adjustment of the PD-Pickups, consult the 
PD-Pickup Mounting Guide.

A.6 Troubleshooting

Some of the technical difficulties which might be encountered when first 
using the PMI System are described below and include useful advice on 
how to correct them.

Long Measurement Time – 'Error' light blinks on PMI Controller:

The PMI Controller automatically changes its measurement range and 
restarts measurement whenever the maximum cylinder pressure exceeds 
approximately 100 bar. When this occurs the red 'Error' light on the control 
box is momentarily lit and the overall time of the measurement increased 
by approximately one minute.

On concluding measurement, the green ‘Ready' button on the control box 
should light, indicating that the PMI System is ready to begin another 
measurement. 

If the red 'Error' button continues to blink without the 'Ready' button light-
ing, then inspect the transducer and PMI Controller plug connections. 
Dirty connections can interfere with the measurement. See section A.3 for 
cleaning.
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Measurement Failure – 'Error' light remains lit on PMI Controller:

If the red 'Error' button on the PMI Controller remains lit and the error 
cannot be cancelled by pressing the button, then there is probably a fault 
with communication or triggering. Activate the 'Communication Log' in 
the Tools' menu for details. See Fig. A-10. 

'Missing TDC Pulses' – Communication Log Warning:

If the 'Communication Log' indicates that the TDC pulses are missing, 
check that the jumper JP3 in the Junction Box is set to 'On' as shown in 
Fig. A-11. If this is not successful, check the trigger system as described in 
section A.4.3 to A.5.3 or in the Installation Guide.

'TDC and Trigger Test Results' Dialogue Displayed on PC:

If at the start or during a measurement the 'TDC and Trigger Test Results' 
dialogue is displayed on the PC, then it is likely that the TDC and crank 
angle signals from the crankshaft pickups are not functioning correctly and 
need to be adjusted to obtain a stable triggering. See section A.4.3 to 
A.5.3. 

Fig. A-10 The 'Communication Log' dialogue
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'PMI Controller address does not match stored engine' 
Error and Status Line Warning on PC:

If a red marker with the warning “PMI Controller address does not match 
stored engine” is flagged at the bottom of the display, select 'Open Engine' 
and the 'Edit' dialogue for the particular engine to which the PMI Control-
ler is connected and then set the engines address to the active engine 
address stated in the error message which is opened with the status line 
warning.

'No Connection to PMI Controller' Status Line Warning on PC:

If a red marker with the warning “No connection to PMI Controller” is 
flagged at the bottom of the display after having set 'Communication On/
Off' to 'On', then check the following:

1. Check that the standard plug of the Converter Box indicated in Fig. 2-2 
is properly secured to one of the communication ports of the PC and 

Fig. A-11 Layout of the PMI System's Junction Box 
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that the appropriate port is chosen in the 'Tools' menu, 'Option' dia-
logue on the PC. See section A.4.1.    

Junction Box 
LED No.

PMI
Controller

Comments24 V
1

15 V
2

5 V
3

Power
On

Off Off Off Off Unscrew and check that the 0.8 A fuse in the 
Junction Box is intact. An extra fuse is included 
in the box for replacement.
Also check that the 24 V DC power input cable 
PMI � 1 is connected correctly, as indicated on 
the print board in the box. 

On Off On/Off Off 15 V power regulation is defective. Replace 
Junction Box.

On On Off On 5 V power regulation is defective. Replace 
Junction Box.

On On On On System is OK.

Table A-1  Junction Box – Supply and Cable Checks 

Fig. A-12 Layout of the PMI System's Converter Box 

Cable PMI � 4 Cable PMI � 5
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Junction Box
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2. Try restarting measurement again and if it fails, check the status of the 
green 'Power On' light of the PMI Controller.

3. If the 'Power On' indicator is not lit, remove the lid of the Junction Box 
to which the PMI Controller is connected and note the status of the 
indicator lights on the printed circuit board in the box. See Fig. A-11.

4. Make the cable connection, fuse and supply checks indicated in 
Table A-1, according to the status of the indicator lights shown above.

5. If the 'Power On' indicator is lit, remove the lid of the Converter Box 
and perform the cable and power supply checks indicated in Table A-2.

Erroneous Measurements:

In the following, examples are given about different types of erroneous 
measurement with hints on how to correct them.

pi indication too high or pmax and pcomp too low:

The indicator cocks of the cylinders in question are probably defective 
and should be repaired or replaced.

PMI Controller
Power On
Indicator

Checks

'On' Remove lid of Converter Box and check that there is 5 V DC 
between terminals no. 5 & 6. See Fig. A�12.

'On'

'On'

If 5 V is not present, check whether it is available between terminals 
no. 12 & 13 of the Junction Box. See Fig. A�11.

If 5 V is present in Junction Box, check the cable PMI � 5 between 
the Junction Box and Converter as the connections are probably 
incorrect.

'On' If 5 V is present in Converter Box, check the connections of cable 
PMI � 4 between the Converter Box and PC.

Table A-2  Converter Box – Supply and Cable Checks
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Negative pi and power indication:

No '0-diagram' has been chosen or the '0-diagram' selected is not a prop-
er '0-Diagram' measurement without fuel injection. See Fig. A-13. 

TDC indication does not match earlier measurements:

The pickup has been moved after the '0-Diagram' was measured. Check 
the trigger system as in section A.5.1.

Flat line in pressure diagram:

The indicator cock has not been opened or the PMI Controller and/or 
transducer are not functioning correctly and should be checked and pos-
sibly replaced. See Fig. A-14. 

Fig. A-13 Erroneous measurement with negative pi and power
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A.7 Technical Assistance

If you experience difficulties in using the PMI System, first carrying out 
the system and maintenance checks given in section A.4 and A.5 of this 
Appendix to see whether you can correct the problem. Additional, help is 
also available in section A.6 and in the separate Mounting and Installation 
Guides which are provided.

If you cannot find the answer, you are welcome to contact MAN B&W 
Diesel A/S, whose address and phone number are given on the back cover 
of this Guide. 

Fig. A-14 Erroneous measurement containing flat line
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When you call by phone, you should have the PMI System documentation 
at hand and be prepared to give the following information:

• The name of the vessel or plant.

• The version and build number of your PMI System indicated under 
'About' in the 'Help' menu.

• The operating system and type of hardware that you are using.

• A brief account of what happened and what you were doing when the 
problem occurred.

• The exact wording of any messages that appeared on your screen.

• Details about how you tried to solve the problem.

When you mail us, we ask you to include the above information, plus any 
relevant computer printouts which might be helpful.
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Glossary

Glossary of Terms

Angle Encoder:

A precision instrument which generates a continuous train of electrical 
pulses for triggering the PMI System in accordance with the rotation 
and angular position of the crankshaft of an engine.

Balance Plot: 

A histogram displaying balance values, e.g. cylinder pressure data, etc.

BDC – Bottom Dead Centre:

The lower most position of the piston. 

Bore:

The diameter of the cylinder. Units: metre.

Calculated Values:

Values derived on the basis of PMI System measurements, e.g. effective 
engine power, pressure deviations and proposed adjustments.

Compression Pressure:

The pressure developed in a cylinder at TDC. Units: bar
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Connecting Rod:

The rod coupling the piston with the crankshaft. The length of the rod 
is defined as the distance between the centres of the bores at either end 
of the rod. Units: metre.

Crank Angle: 

The angle in degrees turned by the crankshaft.

Crank Angle Data:

Preset 'Edit Engine Data' defining the crank angle and firing properties 
of an engine selected with the 'Open Engine' command in the 'File' 
menu. The data can be viewed using the 'Open Engine' – 'Edit' function. 
The properties indicated are:

Crank Angle: The angular position of the start and end of the search 
band for the TDC's of the respective cylinders of the engine. 

As rule of thumb, the end position lies ((360 / 2* number of cylinders) 
+ five) degrees after the nominal position of the cylinder's TDC. 

Firing Order: The sequence in which the respective cylinders of the 
engine fire.

Effective Power:

The power developed by an engine minus the power loss due to friction, 
etc. Units: ekW or bhp. 

E�Load:

Pressure diagram based on pressure measurements on each cylinder tak-
en under stable conditions at an engine load of 50 to 75%, equally dis-
tributed on all cylinders.

The E-Load diagram is used for torsion correction when determining 
the TDC of each cylinder.



Glossary
MAN B&W Diesel

1142958 � 4.6 Off�line PMI System
User’s Guide G � 3

Engine Name / Type / Address Data:

'Edit Engine Data' identifying the name, type and communication ad-
dress of an engine selected with the 'Open Engine' command in the 'File' 
menu. Whereas the engine type is preset, the engine name and address 
can be changed using the 'Open Engine' – 'Edit' function.

Engine Properties:

Preset 'Edit Engine Data' defining the general properties of an engine se-
lected with the 'Open Engine' command in the 'File' menu. The data can 
be viewed using the 'Open Engine' – 'Edit' function and lists the follow-
ing properties:

Bore: The diameter of the engine cylinders. Units: metre.

Stroke: The length of travel of the piston. Units: metre.

Connecting Rod: The distance between the centres of the cross pin and 
crank bearings at either end of the rod. Units: metre.

Kpcomp/pscav: The ratio of cylinder compression and scavenge air pres-
sure. 

Ploss: The mean pressure loss due to friction in the engine. Units: bar.

Engine Speed:

The rotation velocity of the crankshaft, expressed in revolutions per 
minute. Units: rpm. 

Firing Order: 

The sequence in which the cylinders fire.

Index (Adjustment):

A value used to express the amount of fuel oil injected into an engine 
cylinder for adjusting the pi.
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LE�Pickup:

Light emitting sensor which detects the reflective stripes of a continu-
ous strip of zebra tape on an engine crankshaft. Is used for triggering the 
PMI System in accordance with the rotation and angular position of the 
crankshaft of an engine.

MIP:

Abbreviated term referring to mean indicated pressure p(i) or pi

O�Diagram:

Pressure diagram based on pressure measurement on each cylinder tak-
en at an engine load of 50 to 75% without fuel injection (hence without 
combustion) in the cylinder.

The 0-diagram is used when determining the TDC of each cylinder. 

PD�Pickup:

Proximity detector which detects the teeth of a gear wheel or trigger ring 
on an engine. Is used for triggering the PMI System in accordance with 
the rotation and angular position of the crankshaft of an engine.

p(i) Adjustments: 

Preset 'Edit Engine Data' defining the index adjustment properties of an 
engine selected with the 'Open Engine' command in the 'File' menu. The 
data can be viewed using the 'Open Engine' – 'Edit' function. The prop-
erties indicated are:

bar/Index: The change in mean indicated pressure [bars] caused by in-
creasing or decreasing the fuel pump index by one index unit. 

Turn/Index: The number of turns on the fuel pump index rod required 
to increase or decrease the fuel index by one index unit.
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p(i) and p(max) Adjustment Limits: 

Preset 'Edit Engine Data' defining the maximum pressure adjustment 
limits of a two stroke engine selected with the 'Open Engine' command 
in the 'File' menu. The data can be viewed using the 'Open Engine' – 'Ed-
it' function. The properties indicated are:

p(i): The maximum acceptable positive or negative deviation in mean 
indicated pressure allowed between any two cylinders. Units: bar

p(max): The maximum acceptable positive or negative deviation in 
maximum pressure allowed between any two cylinders. Units: bar.

p(com)*/p(scav)*: The maximum cylinder compression (measured as 
absolute values) expressed as a ratio. Is applicable for two stroke ME 
engines only.

p(max) Adjustments: 

Preset 'Edit Engine Data' defining the index adjustment properties of a 
two stroke engine selected with the 'Open Engine' command in the 'File' 
menu. The data can be viewed using the 'Open Engine' – 'Edit' function. 
The properties indicated are:

bar/Shim or bar/Index: The change in maximum pressure caused by 
inserting or removing one shim or by increasing or decreasing the fuel 
index by one index unit.

Turn/Index: The number of turns on the VIT-Index rod required to in-
crease or decrease the VIT-Index by one index unit.

Rotation of Link:

The number of turns required to obtain a certain displacement of the in-
dex rod.

PT Diagram:

Pressure vs. time diagram (draw diagram) showing the change in cylin-
der pressure as a function of the angular position of the cylinder from 
TDC.
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PV Diagram:

Pressure volume diagram (indicator or working diagram, banana curve, 
etc.) showing the change in cylinder pressure as a function of the rela-
tive cylinder volume. The relative cylinder volume is 0% at TDC and 
100% at BDC.

Reference Measurements: 

User selectable engine data identifying which particular set of reference 
measurements (i.e. 0-Diagram and E-Load) that are to be used by de-
fault for correcting the TDC on all future pressure measurements on a 
specific engine. 

All earlier measurements will continue to use the reference measure-
ments that were previously selected as default, provided that they are 
not deleted.

For changing the current reference/default setting, select the 'Edit' func-
tion of the 'Open Engine' command in the 'File' menu. 

Shim Adjustment:

The number of shims to be added or removed in a fuel pump for adjust-
ing pmax.

Stroke:

The length of travel of the piston from TDC to BDC. Units: metre.

Stroke – Engine Type:

The number of piston strokes during one work cycle of an engine.

Stroke and Index Type Info.: 

Preset 'Edit Engine Data' defining the number of strokes of the piston 
during one work cycle and the method of pmax cylinder pressure adjust-
ment of an engine selected with the 'Open Engine' command in the 'File' 
menu. There is the choice of two or four stroke operation, fuel pump ad-
justments, etc.
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The data can be viewed using the 'Open Engine' – 'Edit' function. 

TDC – Top Dead Centre:

The upper most position of the piston. 

Torsion:

The state of strain set up in a body by twisting or applying a torque. 
Units: nRad/Nm.

Torsion Data: 

Preset 'Edit Engine Data' defining the torsional deflection properties of 
an engine selected with the 'Open Engine' command in the 'File' menu. 
The data can be viewed using the 'Open Engine' – 'Edit' function. The 
properties indicated are:

Torsion Coefficient: The torsion coefficients of each section or group 
of sub sections of the crankshaft, starting from the fore end of the crank-
shaft to cylinder No. 1 (i.e. ->1), between cylinder No. 1 & 2 (i.e. 1->2), 
cylinder No. 2 & 3 (i.e. 2->3), cylinder No. 3 & 4 (i.e. 3->4) etc., up to 
the turning wheel (i.e. -> Turn). Units: nRad/Nm.

The values stated are fixed and are based on MAN B&W Diesel's own 
mechanical design and measurement criteria.

Trigger System Information:

User selectable 'Edit Engine Data' for selecting triggering according to 
the location ('Fore' or 'Aft') of the particular crankshaft pickups used on 
the engine. The data can be viewed using the 'Edit' function of the 'Open 
Engine' command in the 'File' menu.

If the triggering system is located at the drive end (normally aft) of the 
crankshaft, the following information is required:

• The diameter of the drive shaft. Units: metre

• The distance of the turning wheel to the triggering system. Units: 
metre.
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VIT (Adjustment):

Variable Injection Timing. A method of controlling the timing of fuel 
oil injected into an engine cylinder for adjusting pmax.

Work Cycle:

Two stroke engines: One work cycle is one full revolution of the crank-
shaft.

Four stroke engines: One work cycle is two full revolutions of the 
crankshaft.
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